KB209: FCK Editor is not loaded
| Article ID |
: |
209 |
| Last Review |
: |
Wednesday, April 09, 2008 |
| Revision |
: |
1 |
SYMPTOMS
When you use FCKEditor, you may notice that editor is not loaded.
CAUSE
This problem occurs because “/” char that starts the base path is set to a none valid root path and in this case doesn’t display anything.
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WORKAROUND
To work around this problem, follow one of this steps:
FCKEditor Project
- Download and Open FCKEditor project
-
Change the BasePath as Follow:
[DefaultValue("/FCKeditor/")]
public string BasePath
{
get
{
if (mstrBasePath == null)
mstrBasePath = System.Configuration.ConfigurationSettings.AppSettings["FCKeditor:BasePath"];
return (mstrBasePath == null ? "../../../../../FCKeditor/" : mstrBasePath);
}
set { mstrBasePath = value; }
}
Your Solution
- Add the FCKEditor.Dll as an reference
- In the Form / Control where you added the FCKEditor, After initialize the control set the FCKEditor.BasePath to "../../../../../FCKeditor/"
<sample code="goes here" />
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STATUS
Gizmox has confirmed that this is a bug in the Gizmox products that are listed in the "Applies to" section.
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Steps to reproduce the behavior
- STEP1
- STEP2
<sample code="goes here" />
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REFERENCES
For more information, click the following article number to view the article in the Gizmox Knowledge Base:
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APPLIES TO
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