Knowledge base
Knowledge Base

KB209: FCK Editor is not loaded

Article ID : 209
Last Review : Wednesday, April 09, 2008
Revision : 1

SYMPTOMS

When you use FCKEditor, you may notice that editor is not loaded.

CAUSE

This problem occurs because “/” char that starts the base path is set to a none valid root path and in this case doesn’t display anything.

Back to the top

WORKAROUND

To work around this problem, follow one of this steps:

FCKEditor Project

  1. Download and Open FCKEditor project
  2. Change the BasePath as Follow:       

[DefaultValue("/FCKeditor/")]

        public string BasePath

        {

            get

            {

                if (mstrBasePath == null)

                    mstrBasePath = System.Configuration.ConfigurationSettings.AppSettings["FCKeditor:BasePath"];

 

                return (mstrBasePath == null ? "../../../../../FCKeditor/" : mstrBasePath);

            }

            set { mstrBasePath = value; }

        }

Your Solution

  1. Add the FCKEditor.Dll as an reference
  2. In the Form / Control where you added the FCKEditor, After initialize the control set the FCKEditor.BasePath to "../../../../../FCKeditor/"


<sample code="goes here" />

 

Back to the top

STATUS

Gizmox has confirmed that this is a bug in the Gizmox products that are listed in the "Applies to" section.

Back to the top

MORE INFORMATION

Steps to reproduce the behavior

  1. STEP1
  2. STEP2
    <sample code="goes here" />

Back to the top

REFERENCES

For more information, click the following article number to view the article in the Gizmox Knowledge Base:
KB_____**KB_TITLE_HERE**

Back to the top

APPLIES TO
  1. All Servers Versions

Back to the top

Copyright © 2005-2008 Visual WebGui®   Terms Of Use  Privacy Statement
Visual WebGui is copyright 2005-2008 by Gizmox