Forum  Core :: SDK (Vi...  Developing the ...  MainMenu subitems strange behavior
Previous Previous
 
Next Next
New Post 2/10/2009 7:14 AM
  davi.sabino
5 posts
No Ranking


MainMenu subitems strange behavior 

Hello.

I have an application that uses a MainMenu control with many submenus. When I select a menuItem, the subitems are  displayed on top of it and its height is limited to the height of the parent menuItem container, so if I have many items in the submenu it won't display all the items. Am I doing something wrong?

 
New Post 2/10/2009 7:35 AM
  jharmon@blinfo.com
880 posts
1st Level Poster




Re: MainMenu subitems strange behavior 

If you are using IE then you have to add the domain name to the trusted sites.  Look under Tools|Internet Options|Security.  Click on the trusted sites option and add your domain name to it.  VWG is there any way to not have to do this?  This is going to be a real pain when trying to deploy.


Thanks, Joe
 
New Post 2/10/2009 11:59 AM
  davi.sabino
5 posts
No Ranking


Re: MainMenu subitems strange behavior 

I tried doing that but it didn't work. I noticed it's working fine in IE 6 and in firefox, but not in IE 7 even with low security settings.

 
New Post 2/10/2009 2:13 PM
  palli
17187 posts
1st Level Poster




Re: MainMenu subitems strange behavior 

Hi guys,

What version of VisualWebGUI are we talking about ?

I tried reproducing what you describe in 6.2.4 and 6.3.0 and was unable to. Working both in IE7 and FF3.

Best way to describe those problems is by creating a most minimal application that demonstrates the problem(s) and then send your application to support [at] visualwebgui [dot] com with a link to this forum thread, along with some description about how to reproduce the problem.

Please also clean the solution before compressing it and reply to this post after sending, so we will know to check for your support request.

In this case, I think it would help to receive an image of the effect you are reporting as error, just in case we are unable to reproduce.

Palli

 


Páll Björnsson - Visual WebGui Community Manager - Email: support@visualwebgui.com

Please include VWG version information with your questions (best: Full name of VWG installation .MSI file)
To send sample code or other files to support, first zip the relevant project or files,
then rename .ZIP file to different extension like .XIP and finally email as attachment to email address above.
Remember to include full Http Url to the forum thread in the message.
 
New Post 2/11/2009 6:08 AM
  davi.sabino
5 posts
No Ranking


Re: MainMenu subitems strange behavior 

I'm using build 6.3 in Ajax mode. It works fine in Silverlight mode. I just put a menu in a form, add two item in it, then add three subitems in one of the menuitems and the problem happens. Even in the catalog application available for download here the problem is happening:

http://img3.imageshack.us/img3/5108/menunt9.jpg

 

 
Previous Previous
 
Next Next
  Forum  Core :: SDK (Vi...  Developing the ...  MainMenu subitems strange behavior